const regex = /(?:^\d+:[^:\r\n]+:$|^:[^:\r\n]+:\d+$|^(?!.*:\b\S+\b:).*$)(*SKIP)(*FAIL)|:[a-z0-9]+:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^\\d+:[^:\\r\\n]+:$|^:[^:\\r\\n]+:\\d+$|^(?!.*:\\b\\S+\\b:).*$)(*SKIP)(*FAIL)|:[a-z0-9]+:', 'gm')
const str = `:match1::match2: :match3:
:match4:
000:matchNot:
:matchNot:000
:match Not:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}