re = /(?:^\d+:[^:\r\n]+:$|^:[^:\r\n]+:\d+$|^(?!.*:\b\S+\b:).*$)(*SKIP)(*FAIL)|:[a-z0-9]+:/m
str = ':match1::match2: :match3:
:match4:
000:matchNot:
:matchNot:000
:match Not:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end