#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-z])[a-z0-9_.-]{3,10}$"
Local $sString = "abcdef" & @CRLF & _
".-abc123" & @CRLF & _
"123a456" & @CRLF & _
"123456" & @CRLF & _
"123456789abcdefghi" & @CRLF & _
"abcABCdef"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")