$re = '/^(?=.*[a-z])[a-z0-9_.-]{3,10}$/m';
$str = 'abcdef
.-abc123
123a456
123456
123456789abcdefghi
abcABCdef';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);