re = /^(?=.*[a-z])[a-z0-9_.-]{3,10}$/m
str = 'abcdef
.-abc123
123a456
123456
123456789abcdefghi
abcABCdef'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end