# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\/]*[^\/a-zA-Z][^\/]*/*/gm;t' <<< "/first/12ab34/B1a234/12B3a/1234/second/A789B-89d"