re = /[^\/]*[^\/a-zA-Z][^\/]*/m
str = '/first/12ab34/B1a234/12B3a/1234/second/A789B-89d'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result