using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^/]*[^/a-zA-Z][^/]*";
string substitution = @"*";
string input = @"/first/12ab34/B1a234/12B3a/1234/second/A789B-89d";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}