const regex = /^(?:[a-z\d]{3,}[_ ](?:[a-z\d]{2,}[_ ][a-z\d]{4,})?)?[a-z\d]*$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[a-z\\d]{3,}[_ ](?:[a-z\\d]{2,}[_ ][a-z\\d]{4,})?)?[a-z\\d]*$', 'igm')
const str = `Valid:
a
b1
abcdefg
123_VBV
123_ABC_ERRR
12345
123456789abcdefg
123_AB_YYYY
123_ABC_YYYY
Invalid:
123__
123_gg_
_12345
1 2345
123 a_bc
123_ 45
123__45
123 45
123_gg_
123_VBV_HH_
Foo_Bar_Baz_123
Foo Bar_Baz_123
123_AB_YYY
123_ggg_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}