use strict;
my $str = 'Valid:
a
b1
abcdefg
123_VBV
123_ABC_ERRR
12345
123456789abcdefg
123_AB_YYYY
123_ABC_YYYY
Invalid:
123__
123_gg_
_12345
1 2345
123 a_bc
123_ 45
123__45
123 45
123_gg_
123_VBV_HH_
Foo_Bar_Baz_123
Foo Bar_Baz_123
123_AB_YYY
123_ggg_';
my $regex = qr/^(?:[a-z\d]{3,}[_ ](?:[a-z\d]{2,}[_ ][a-z\d]{4,})?)?[a-z\d]*$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}