re = /^(?:[a-z\d]{3,}[_ ](?:[a-z\d]{2,}[_ ][a-z\d]{4,})?)?[a-z\d]*$/im
str = 'Valid:
a
b1
abcdefg
123_VBV
123_ABC_ERRR
12345
123456789abcdefg
123_AB_YYYY
123_ABC_YYYY
Invalid:
123__
123_gg_
_12345
1 2345
123 a_bc
123_ 45
123__45
123 45
123_gg_
123_VBV_HH_
Foo_Bar_Baz_123
Foo Bar_Baz_123
123_AB_YYY
123_ggg_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end