using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{%\s+(\S+)\s+IF:.+?%}(?s)(.+?){%\s+\1\s+ENDIF\s+%}";
string input = @"{% name IF: a EQUALS b %}
content
{% name ENDIF %}
{% Saffi IF: my { % dog } has fleas %}
content
{% Saffi ENDIF %}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}