$re = '/{%\s+(\S+)\s+IF:.+?%}(?s)(.+?){%\s+\1\s+ENDIF\s+%}/m';
$str = '{% name IF: a EQUALS b %}
content
{% name ENDIF %}
{% Saffi IF: my { % dog } has fleas %}
content
{% Saffi ENDIF %}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);