const regex = /{%\s+(\S+)\s+IF:.+?%}(?s)(.+?){%\s+\1\s+ENDIF\s+%}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{%\\s+(\\S+)\\s+IF:.+?%}(?s)(.+?){%\\s+\\1\\s+ENDIF\\s+%}', 'gm')
const str = `{% name IF: a EQUALS b %}
content
{% name ENDIF %}
{% Saffi IF: my { % dog } has fleas %}
content
{% Saffi ENDIF %}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}