const regex = /\B(?:#|#)((?![\p{N}ـ_]+(?:$|\b|\s))(?:[\p{L}\p{M}\p{N}_]{1,60}))/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B(?:#|#)((?![\\p{N}ـ_]+(?:$|\\b|\\s))(?:[\\p{L}\\p{M}\\p{N}_]{1,60}))', 'ug')
const str = `#test
#5555
#weekend10
#55_555
#المكان
#٢٢٢
#تجرب١٢
#ـ٥٥
#44test
#55_test
#9yo
#dope10
#10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}