$re = '/\B(?:#|#)((?![\p{N}ـ_]+(?:$|\b|\s))(?:[\p{L}\p{M}\p{N}_]{1,60}))/u';
$str = '#test
#5555
#weekend10
#55_555
#المكان
#٢٢٢
#تجرب١٢
#ـ٥٥
#44test
#55_test
#9yo
#dope10
#10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);