re = /\B(?:#|#)((?![\p{N}ـ_]+(?:$|\b|\s))(?:[\p{L}\p{M}\p{N}_]{1,60}))/
str = '#test
#5555
#weekend10
#55_555
#المكان
#٢٢٢
#تجرب١٢
#ـ٥٥
#44test
#55_test
#9yo
#dope10
#10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end