#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<!--.*-->"
Local $sString = "bonjour," & @CRLF & _
"<!-- commentaire" & @CRLF & _
"très utile -->" & @CRLF & _
"comment allez-vous?" & @CRLF & _
"<!-- commentaire encore" & @CRLF & _
" plus utile -->" & @CRLF & _
"aujourd'hui"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")