$re = '/<!--.*-->/s';
$str = 'bonjour,
<!-- commentaire
très utile -->
comment allez-vous?
<!-- commentaire encore
plus utile -->
aujourd\'hui';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);