re = /<!--.*-->/
str = 'bonjour,
<!-- commentaire
très utile -->
comment allez-vous?
<!-- commentaire encore
plus utile -->
aujourd\'hui'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end