using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:
(?:
(?<=[(-+*/])
|(?<=[(-+*/]\s)
)
-)?
\d+(?:\.\d+)?
|
[-+*/()]";
string input = @"(-15 -14)
(-25-5 * 2)
(-25.5 * 2)
(-25.5 * -2)
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}