import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\n"
+ " (?:\n"
+ " (?<=[(-+*/])\n"
+ " |(?<=[(-+*/]\\s)\n"
+ " )\n"
+ "-)?\n"
+ "\\d+(?:\\.\\d+)?\n"
+ "|\n"
+ "[-+*/()]";
final String string = "(-15 -14)\n\n"
+ "(-25-5 * 2)\n"
+ "(-25.5 * 2)\n"
+ "(-25.5 * -2)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}