$re = '/(?:
(?:
(?<=[(-+*/])
|(?<=[(-+*/]\s)
)
-)?
\d+(?:\.\d+)?
|
[-+*/()]/mx';
$str = '(-15 -14)
(-25-5 * 2)
(-25.5 * 2)
(-25.5 * -2)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);