using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S*mycommand\s+(?:-\S+\s+)*(?|""([^""]*?)\/?""|(\S+)(?<!\/)).*";
string input = @"mycommand --optional-arguments path/to/dir arg1 arg2
mycommand --optional-arguments /path/to/dir arg1 arg2
mycommand --optional-arguments path/to/dir/ arg1 arg2
mycommand --optional-arguments ""path/to/dir"" arg1 arg2
mycommand --optional-arguments ""/path/to/dir"" arg1 arg2
mycommand --optional-arguments ""path/to/dir/"" arg1 arg2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}