re = /\S*mycommand\s+(?:-\S+\s+)*(?|"([^"]*?)\/?"|(\S+)(?<!\/)).*/m
str = 'mycommand --optional-arguments path/to/dir arg1 arg2
mycommand --optional-arguments /path/to/dir arg1 arg2
mycommand --optional-arguments path/to/dir/ arg1 arg2
mycommand --optional-arguments "path/to/dir" arg1 arg2
mycommand --optional-arguments "/path/to/dir" arg1 arg2
mycommand --optional-arguments "path/to/dir/" arg1 arg2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end