$re = '/\S*mycommand\s+(?:-\S+\s+)*(?|"([^"]*?)\/?"|(\S+)(?<!\/)).*/m';
$str = 'mycommand --optional-arguments path/to/dir arg1 arg2
mycommand --optional-arguments /path/to/dir arg1 arg2
mycommand --optional-arguments path/to/dir/ arg1 arg2
mycommand --optional-arguments "path/to/dir" arg1 arg2
mycommand --optional-arguments "/path/to/dir" arg1 arg2
mycommand --optional-arguments "path/to/dir/" arg1 arg2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);