package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<type>[+-])?(?P<path>[^:]+?)(?::(?P<contract>[^.])(?:\.(?P<function>.+)?)?)?$`)
var str = `sub1/A.sol:A
sub1/sub2/baba.sol:constructor
sub_folder/*:A.test_*
*:*.payable
sub1/*:A
-sub1/sub2/A.sol:A.test
+*:*.*
sub1/A.sol:A.a
:not-matching:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}