use strict;
my $str = 'sub1/A.sol:A
sub1/sub2/baba.sol:constructor
sub_folder/*:A.test_*
*:*.payable
sub1/*:A
-sub1/sub2/A.sol:A.test
+*:*.*
sub1/A.sol:A.a
:not-matching:';
my $regex = qr/^(?P<type>[+-])?(?P<path>[^:]+?)(?::(?P<contract>[^.])(?:\.(?P<function>.+)?)?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}