// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<type>[+-])?(?P<path>[^:]+?)(?::(?P<contract>[^.])(?:\.(?P<function>.+)?)?)?$").unwrap();
let string = "sub1/A.sol:A
sub1/sub2/baba.sol:constructor
sub_folder/*:A.test_*
*:*.payable
sub1/*:A
-sub1/sub2/A.sol:A.test
+*:*.*
sub1/A.sol:A.a
:not-matching:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}