# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#\d+=.*?'Volume\(m3\).*?\bIFC\KLABEL\b/REAL/gm;t' <<< "#425=IFCPROPERTYSINGLEVALUE('Volume(m3)',$,IFCLABEL('0.1'),$);
"