using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#\d+=.*?'Volume\(m3\).*?\bIFC\KLABEL\b";
string substitution = @"REAL";
string input = @"#425=IFCPROPERTYSINGLEVALUE('Volume(m3)',$,IFCLABEL('0.1'),$);
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}