package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\t:]*(from (.*?)[ ]*|)import (.*?)(| as (.*?))[\n]`)
var str = `import os
import os as test
from RegistryController import RegistryController
from ui.windows.lists import ListCtrl, DynamicListCtrl
from main.core import Exceptions
from Queue import Queue
from main.core.MessageQueue import Queue as MessageQueue
from os import test as test
for i in range(50):import os
import os
for i in range(50):
import os
print("We are importing this new, import ajid.")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}