# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\t:]*(from (.*?)[ ]*|)import (.*?)(| as (.*?))[\n]"
test_str = ("import os\n"
"import os as test\n"
"from RegistryController import RegistryController\n"
"from ui.windows.lists import ListCtrl, DynamicListCtrl\n"
"from main.core import Exceptions\n"
"from Queue import Queue\n"
"from main.core.MessageQueue import Queue as MessageQueue\n"
"from os import test as test\n"
"for i in range(50):import os\n"
" import os\n"
" for i in range(50):\n"
" import os\n"
" print(\"We are importing this new, import ajid.\")")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.