import Foundation
let pattern = #"[\t:]*(from (.*?)[ ]*|)import (.*?)(| as (.*?))[\n]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
import os
import os as test
from RegistryController import RegistryController
from ui.windows.lists import ListCtrl, DynamicListCtrl
from main.core import Exceptions
from Queue import Queue
from main.core.MessageQueue import Queue as MessageQueue
from os import test as test
for i in range(50):import os
import os
for i in range(50):
import os
print("We are importing this new, import ajid.")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)