using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[=-]?[0-9]+(\.[0-9]*)?$";
string input = @"1231231231231231231
asdjasdjasd123
12123123.12312
1982737.122
-123.123
-22";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}