$re = '/^[=-]?[0-9]+(\.[0-9]*)?$/m';
$str = '1231231231231231231
asdjasdjasd123
12123123.12312
1982737.122
-123.123
-22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);