package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"]*"|\h+|[^\h"]+`)
var str = `ADD r2, r3[]"ADD[]r2,[]r3"
ADD r2, r3
"ADD r2, r3" "foo bar"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}