import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\"]*\"|\\h+|[^\\h\"]+";
final String string = "ADD r2, r3[]\"ADD[]r2,[]r3\"\n"
+ "ADD r2, r3\n"
+ "\"ADD r2, r3\" \"foo bar\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}