#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z]*\d[a-z]*?(?<=^.{5}$)"
Local $sString = "jlwk6" & @CRLF & _
"bjkgp" & @CRLF & _
"5fm8s" & @CRLF & _
"x975t" & @CRLF & _
"k88q5" & @CRLF & _
"zl796" & @CRLF & _
"qm9hb" & @CRLF & _
"h6gtf" & @CRLF & _
"9rm9p" & @CRLF & _
"jwzw2" & @CRLF & _
"jlwk6a" & @CRLF & _
"bjkgpa" & @CRLF & _
"5fm8sa" & @CRLF & _
"x975ta" & @CRLF & _
"k88q5a" & @CRLF & _
"zl796a" & @CRLF & _
"qm9hba" & @CRLF & _
"h6gtfa" & @CRLF & _
"9rm9pa" & @CRLF & _
"jwzw2a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")