$re = '/^[a-z]*\d[a-z]*?(?<=^.{5}$)/m';
$str = 'jlwk6
bjkgp
5fm8s
x975t
k88q5
zl796
qm9hb
h6gtf
9rm9p
jwzw2
jlwk6a
bjkgpa
5fm8sa
x975ta
k88q5a
zl796a
qm9hba
h6gtfa
9rm9pa
jwzw2a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);