import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z]*\\d[a-z]*?(?<=^.{5}$)";
final String string = "jlwk6\n"
+ "bjkgp\n"
+ "5fm8s\n"
+ "x975t\n"
+ "k88q5\n"
+ "zl796\n"
+ "qm9hb\n"
+ "h6gtf\n"
+ "9rm9p\n"
+ "jwzw2\n"
+ "jlwk6a\n"
+ "bjkgpa\n"
+ "5fm8sa\n"
+ "x975ta\n"
+ "k88q5a\n"
+ "zl796a\n"
+ "qm9hba\n"
+ "h6gtfa\n"
+ "9rm9pa\n"
+ "jwzw2a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}