using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$(\s[\d,]+(?:\.\d+)?)";
string input = @"$1360
$1
$2 wfwfewfw
$ 200 000 wefwewf
$ 5 000
$5
$ 500
$50
$500";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}