import Foundation
let pattern = #"\$(\s[\d,]+(?:\.\d+)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$1360
$1
$2 wfwfewfw
$ 200 000 wefwewf
$ 5 000
$5
$ 500
$50
$500
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)