// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$(\s[\d,]+(?:\.\d+)?)").unwrap();
let string = "$1360
$1
$2 wfwfewfw
$ 200 000 wefwewf
$ 5 000
$5
$ 500
$50
$500";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}