package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?ms)Remote host:\s+(?<Remotehost>\d+\.\d+\.\d+\.\d+)`)
var str = `Remote host:
2.136.12.186
:34126]@684574 useCount=1 bytesRead=0 bytesWritten=2994631 age=163708ms lastIO=5ms ))).onExceptionWrite exception`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}