$re = '/(?ms)Remote host:\s+(?<Remotehost>\d+\.\d+\.\d+\.\d+)/m';
$str = 'Remote host:
2.136.12.186
:34126]@684574 useCount=1 bytesRead=0 bytesWritten=2994631 age=163708ms lastIO=5ms ))).onExceptionWrite exception';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);