re = /(?ms)Remote host:\s+(?<Remotehost>\d+\.\d+\.\d+\.\d+)/m
str = 'Remote host:
2.136.12.186
:34126]@684574 useCount=1 bytesRead=0 bytesWritten=2994631 age=163708ms lastIO=5ms ))).onExceptionWrite exception'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end