using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A?[^A]+";
string input = @"56-3#AJ4klAP0W
A56-3#AJ4klAP0W";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}