package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)A?[^A]+`)
var str = `56-3#AJ4klAP0W
A56-3#AJ4klAP0W`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}