$re = '/A?[^A]+/m';
$str = '56-3#AJ4klAP0W
A56-3#AJ4klAP0W';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);